How to install Metasploit in Termux – Easiest Way(No root!)

Welcome back, fellow security enthusiasts! Termux, a free Terminal Emulator for Android, gained a lot of attention lately. The first thing that came to my mind after installing it was: Can it run our favorite Penetration Testing Tool Metasploit?! And sure enough, it can! One of the best parts is, it doesn’t even require a rooted device! The installation is also very easy, thanks to a script provided by a Github user named “Auxilus”. Let’s start, I’ll show you how to install Metasploit in Termux.

There are two ways to install it, using Auxilus’s script, or going the manual way. Out of convenience, we only cover the easy way here. If you want to go the Manual Route, click here.

 

 

Step 1 – Installing Termux

If you haven’t already, go ahead and install Termux first. Simply open the Google Play Store on Android and type “Termux” in the search field. Click Install to install it and Open to open it once it’s done.

How to install Metasploit in Termux

 

Step 2 – Installing wget and downloading the Script

First, make sure you are in the home directory by typing:

cd $HOME

Followed by:

pkg install wget

To install wget.

 

Now we need to download Auxilus’s script from Github using wget:

wget https://Auxilus.github.io/metasploit.sh

How to install Metasploit in Termux

 

 

Step 3 – Install Metasploit in Termux

To run the installer simply type:

bash metasploit.sh

This starts the Metasploit installation, doing all the jobs for you-you otherwise would have to do manually.

How to install Metasploit in Termux

 

Step 4 – Starting Metasploit

You are already done! To start Metasploit type:

msfconsole

How to install Metasploit in Termux

 

Conclusion

How easy was that, right? Now you can run Metasploit from your Mobile Phone! I haven’t had time yet to dig deeper in it, but I’m definitely planning to try out a couple of things. I’m very interested if I can plug in my trusted ALFA AWUSH036H to my phone and run some Wi-Fi testing from there.

Once I get to test some stuff, future tutorials will follow. Stay tuned and stay curious!

 

4 thoughts on “How to install Metasploit in Termux – Easiest Way(No root!)

  • June 3, 2019 at 4:09 pm
    Permalink

    E: Unable to locate package metasploit-framework

    people I just came across this error can anyone assist me please.

    Reply
  • January 22, 2019 at 12:08 am
    Permalink

    Failed to install nokogiri

    Reply
  • January 21, 2019 at 1:51 am
    Permalink

    Bundler installer, above that it’s written failed to install nokogiri 1.8.4

    Reply

Tell us what you think!

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: